Version History

<table>
<thead>
<tr>
<th>Version</th>
<th>Release Date</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>13.0</td>
<td>17/2/20</td>
<td>New features, improvements and fixes.</td>
</tr>
</tbody>
</table>

Version 13.0

Upgrade Procedure

1. Upgrading from: All Platforms:

   Please note that version 12.0 and above will require an AvoKey dongle. This can be purchased from Avolites and is included free of charge for new consoles purchased from 1st June 2019. For consoles where it is not already pre-installed this will need to be licensed and must be inserted in the correct USB port (please refer to AvoKey installation instructions) for the software to be licensed and run. You can find detailed information about the AvoKey dongle and the licensing procedure [here](#).

2. Upgrading from: Consoles 12.0 and above:

   Please ensure you save and backup your shows before attempting to upgrade any software. An automated upgrade path from Titan 12.0 and above is provided. You can download the latest Titan software by clicking on the relevant console [here](#). Full instructions for upgrading both with an installer and a recovery stick are supplied with the download and can be found in the console manual. The installer upgrade procedure is reproduced briefly below: Please save the software to the root directory of a USB stick or other storage device. Insert the USB stick in the console and select Control Panel > Titan Installers > Titan 13.0 Setup on the tools menu. Follow the instructions presented by the installer, taking care to read each step carefully. Once the setup completes you need to restart the console. When the console restarts it should be updated to the new software; please check this by reading the version number in system mode.

3. Upgrading from: PC any version:

   Supported versions of Windows are 64-bit versions of Windows 10. This affects Titan Go, Titan Mobile, Titan Simulator and Personality Builder. Please ensure you save and backup your shows before attempting to upgrade any software. You can download the latest Titan software [here](#). When it has finished downloading find the setup file and double click to run it. Follow the instructions presented by the installer, taking care to read each step carefully. Once the setup completes you need to restart the computer. This requires an AvoKey which must be inserted in one of the USB ports. If you have not done so previously follow the instructions in the Authenticator to license the software. Once licensed it should be updated to the new software.

4. Upgrading from: Titan Remote Apps:

   Users wishing to use Titan Remote with version 13.0 should download the new Titan Remote V13 app from the relevant app store. The existing apps will continue to work with previous Titan software versions. Please note the Known Issues for the Android app.

New Features

1. Playback Groups:

   A new feature called Playback Groups has been added. This provides a way to create a collection of playbacks which, by default, are mutually exclusive with one another where firing a playback will kill any other live playbacks in the same playback group and where only one playback in each playback group can be active at any given time.

   A new [Playback Groups] softkey has been added to the ‘Groups’ menu (accessed by pressing the GROUP key). Selecting this will open the ‘Playback Groups’ menu where you can create, edit and view playback groups.

   [Record playback group] will open the ‘Record Playback Group’ menu where you can select (or deselect) playbacks to be included in a group. [Legend] can be used to input a legend if
required (if no legend is set the group will be named 'Playback Group <user number>'). By default the user number will be set to the next available but if required you can change this by selecting [User Number]. If the user number is not currently in use [Store] or <enter> will create a new playback group. If the user number is in use [Merge] will add any new playbacks to the selected group (the existing legend for the playback group will be preserved and any legends set in the 'Record Playback Group' menu will be discarded). [Replace] will replace any existing playbacks in that group (if a new legend has been set this will be used, otherwise the existing legend will be preserved).

[Edit playback group] or <enter> will open the 'Edit Playback Group' menu and highlight any playbacks currently in the selected group. You can change the group being edited by selecting [User Number] and while in this menu you can add or remove playbacks from the selected group and change its legend via [Legend]. [Delete] will open a confirmation menu where [Delete playback group] or <enter> will delete the selected group and [Cancel] will return to the 'Edit Playback Group' menu. [Renumber] will open the 'Renumber Playback Group' menu where you can change the selected group user number. If the new number is not currently in use [Renumber] or <enter> will apply the new user number. If the new number is currently in use [Swap user numbers] or <enter> will swap the user numbers.

A new Playback Groups window has been added. This provides a way to view all the existing groups and their playbacks along with an alternative way to create and edit. This can be opened by selecting [Playback Groups] from the 'Open Workspaces Window' menu (accessed by selecting [Open Workspace Window] from the Program menu or OPEN/VIEW -> [Open Workspace Window]) or by selecting [View All] from the 'Playback Groups' menu (GROUP -> [Playback Groups]).

By default the Playback Groups window will show any existing playback groups on the left side and, with the 'Playbacks' tab selected, any associated playback handles to the right. Each playback group section will dynamically expand as necessary to show all of the included playbacks and a scroll bar will appear if it is not possible to show everything within the current window size. The + button will add a new playback group and the edit button will open the 'Edit Playback Group' menu. In addition to inputting a user number, the group being edited can also be selected from the Playback Groups window where it will highlight in red. If a group is selected prior to pressing the edit button that group will initially be selected for editing. Pressing the + button while in the 'Edit Playback Group' menu will add a new group containing any selected playbacks.

The playback handles in the Playback Groups window are mirrors of their counterparts. They can be fired/killed/released/etc. as normal and many operations such as [Playback Options], [Set Legend], View and Record -> merge/convert can be performed on the these handles in the same way as their counterparts with any changes reflected in both (where a playback is assigned to a fader firing it from the Playback Groups window will set it to full).

Where a playback is included in one or more playback groups a star symbol will appear on the playback legend or corner of touch playback handles to indicate it is included in a group and by default firing a playback included in a playback group will kill any other active playbacks included in that group.

Pressing RECORD will reveal a pulsing + after the last handle in all the groups. Selecting this will add a new playback directly into the selected playback group (this will also be assigned to a handle in the Playbacks window). You can also COPY and MOVE one or more playbacks using this method. Moving a handle from one playback group to another will add it to the target if it doesn't already exist and remove it from the source. When selecting a source handle outside of the Playback Groups window the move operation will only attempt to add the handle to the playback group - the source will remain unaffected. Pressing DELETE and selecting one or more playback handles in the Playback Groups window will highlight the handles and associated group in red and open the 'Remove Playback from Playback Group' menu with a prompt to confirm if you want to remove the selected playbacks from the playback group. [Replace playbacks from playback group], <enter> or selecting the playback handles again will remove the selected playbacks from that playback group.

Selecting the 'Options' tab will reveal settings for the selected group:

- 'Mutually Exclusive' toggles whether the playbacks in the group are mutually exclusive (on) or not (off). By default this is set to on.
- 'Kill Point' determines the point at which a playback in the group kills mutually exclusive playbacks. When set to 'Fired' playbacks will be killed at the point another playback in the group is fired. When set to 'Fade Completed' playbacks will be killed when another playback in the group has finished fading in (where a playback is assigned to a fader and fired by lifting the fader the fade is considered complete only when the fader is at full and any timed fades are finished). By default this is set to 'Fade Completed'.
- 'Kill Action' determines how mutually exclusive playbacks are killed. When set to 'Follow Playback' playbacks will be killed according to their own settings. When set to 'Kill' playbacks will always be killed. When set to 'Release' playbacks will always be released and when set to 'Release HTP' HTP controls in playbacks will always be released and LTP controls will be killed. By default this is set to 'Follow Playback'.
- 'Release Mask' determines which attributes are released when playbacks are killed.
Selecting the release mask button will reveal a popup and open the 'Playback Groups Release Mask' menu. When the Mask Source is set to 'Playback' (default) they will use the release mask set on the individual playbacks. Toggle this to 'Local' to set a release mask specific to the group where the various attributes can be toggled between 'Include' (highlighted) and 'Exclude' by pressing on the relevant button in the popup, by selecting the relevant softkey or by pressing the associated attribute bank buttons. When the Mask Source is set to 'Local' any included attributes are shown in the release mask button with the relevant IPGCBESFXTTime indicators and these will be preserved when changing between Mask Source 'Local' and 'Playback'.

- 'Release Time' determines the time that any attributes from exclusive playbacks are released over (according to release mask). When set to 'Playback' (default) the individual playback release time will be used. By selecting this you can input a release time specific to the group.

Button and text size can be adjusted in the Playback Group window Appearance settings. Button size only affects the playback handles and text size affects both the playback handles and groups. There is also a 'View Mode' toggle. By default this is set to 'View Mode All' which displays a handle representing each group as well as all the playback handles associated with each group. 'View Mode Single' simplifies this so that it only shows the playback handles for the selected group. 'View Mode Playbacks Only' is similar to 'View Mode All' in that it shows all of the playback handles associated with each of the groups but here instead of a separate column containing handles representing each of the groups everything is in one place with just the playback group text legend shown as a title. Note that it is not possible to select playback groups when the window appearance is set to 'View Mode Playbacks Only' and the tabs, add and edit buttons will disappear although it is still possible to access the add and edit functions via GROUP -> [Playback Groups]. As with other windows these appearance settings will store and recall from workspace shortcuts.

2. **Pioneer DJ BPM Triggers:**

It is now possible to use compatible Pioneer DJ products to set the speed of BPM masters. This will work with any Pioneer DJ products that are compatible with the Pioneer Pro DJ Link Bridge application such as the CDJ-2000NXS2.

To use this you need ensure the Pioneer 'Pro DJ Link Bridge' application is running. On consoles this can be found in the Tools -> Additional Programs menu. If desired you can set this to automatically run when the console is started via Tools -> Control Panel -> Run on Startup -> Pro DJ Link Bridge. On PC this can be found under Start Menu -> PRO DJ LINK Bridge -> PRO DJ LINK Bridge.

Note that the Pioneer equipment does not allow you to set an IP address and therefore needs to be on a network with DHCP enabled or auto-assigned IP in the format 169.254.*.* which is assigned through mDNS. On consoles setting the network address to DHCP will facilitate this but please be aware that you will not be able to use that adapter for anything else. If Art-Net or sACN is required you will need to ensure it is on a separate network adapter to the Pioneer equipment.

Any compatible products connected on the same network as Titan will highlight in green at the bottom of the Pro DJ Link Bridge window along with the product model name. If the products do not appear check the correct interface is selected in PRO DJ LINK and TCNET.

With compatible products successfully connected you can assign them as triggers for BPM masters. With a BPM master assigned to a handle go to System menu (AVO+DISK) -> [Triggers] -> [Add New] -> <input a name> -> [OK] -> [Add Trigger] -> [Trigger Type Item] -> <select relevant BPM master> (at this point the a [PioneerDJ] action will automatically appear - currently this is the only action available for BPM masters) -> [OK]. By default the BPM source will be the 'Master' deck. If required you can toggle this to be specific deck via the [Deck] softkey. Finally select [Add] to create the trigger. The master or chosen deck will now control the speed of the associated BPM master.

A factory macro called 'Pioneer DJ On/Off' has also been added. This provides a way to toggle the BPM link on/off so that you can easily switch between deck and local control.

If a product being used as a source for a trigger is lost (for example if the network cable is unplugged) 'CDJ bound to BPM master lost. Touch here to clear this warning.' will appear in the prompt area.

3. **Pioneer DJ Workspace:**

A new window called 'PioneerDJ' has been added. This provides a way to view track information for any compatible Pioneer DJ products connected via the Pro DJ Link Bridge application along with a way to choose the master deck and a switch to enable/disable BPM triggers.

Selecting [PioneerDJ] from the Open Workspace Window menu will open the 'PioneerDJ' window and, by default, any successfully connected compatible products will highlight in green in the status bar section at the bottom of this window where a toggle switch to enable/disable
BPM triggers can also be found. By default track details (track name and artist), a big and small waveform with current play head position, play state icon (stopped/paused/playing) and time elapsed/remaining are shown for each of the devices along with the device number and a button to set as master. Selecting the 'M' button will set that player as the master. The 'M' will indicate the current master in red.

The context menu provides a number of toggles to customise the window:

- 'Big Waveform Shown/Hidden' determines whether the big waveform is displayed (default is shown)
- 'Small Waveform Shown/Hidden' determines whether the small waveform is displayed (default is shown)
- 'Track Details Shown/Hidden' determines whether the track name and artist are displayed (default is shown)
- 'Status Bar Shown/Hidden' determines whether the status bar is displayed (default is shown)
- Zoom sets the zoom level of the big waveform to either 10%, 25%, 50%, 75% or 100%. This is similar to the zoom options on the products. Default is 100%
- Selecting 'Change Layout' will reveal a PioneerDJ Layout submenu. 'Full' displays all of the chosen information for all of the connected products. 'Master' displays the chosen information for the selected master only and 'Condensed' displays the chosen information for the selected master along with just the BPM, the master switch and (if set to shown) the track details for other connected products.

Selecting the 'Assign Triggers' button will open the Triggers menu.

Note that in order for the waveforms and play head position to work correctly tracks need to have been analysed by and exported from RekordBox (the Pioneer equipment does not do any of the analysis and also relies on this for the waveform displays).

**Improvements**

1. **More BPM masters:**
   The number of BPM masters has been increased from 4 to 8.

2. **Third party MIDI driver compatibility:**
   The USB MIDI implementation has been updated to be compatible with third-party MIDI drivers or devices.

**Bugs Fixed**

1. **Winamp control breaks when not patched to 1.001:**
   Previously if a Winamp fixture was not (or could not be) patched to line 1, address 001 it would not control the application correctly. This has now been fixed so that it does not matter which line or address it is patched to.

2. **NDI streams are never closed and build up:**
   Fixed an issue where NDI previews would not be closed and continue to run on the network when changing the layout or closing the Video Multi View window and re-opening the window would add new streams causing high network traffic resulting in a reduction in the quality of the NDI preview and integrated Capture Visualiser.

3. **Titan would not be discovered if OpenSLP is installed as a Discovery Agent:**
   Fixed an issue where Titan would not be discoverable on a machine where OpenSLP is installed as a discovery agent.

**Known Issues**

1. **Titan V12.1 is removed by a V12.0 Factory Recovery:**
   If a recovery is run on a console running V12.1, and a 'Factory Restore' is selected, then after the recovery the console will be running V12.0, not V12.1 as expected. To resolve this, users can either choose to run a 'Standard Recovery' instead of a 'Factory Recovery', or users can manually install V12.1 after running a 'Factory Restore'.

2. **PC Suite upgrade installers can cause the CodeMeter WebAdmin interface to be inaccessible:**
   If a PC Suite Upgrade Installer is run, then the CodeMeter WebAdmin interface will no longer be accessible. Users needing to access this interface can resolve this by manually re-installing the full CodeMeter runtime after running the PC Suite Installer.
3. **Downgrading to pre-V12 versions is unsupported:**

   Please note that using upgrade installers for older versions of Titan after running the V12 recovery is not currently supported and will prevent the console from starting if attempted. If you need to downgrade to a previous version it is important that this is done via a relevant recovery stick only. Consoles not starting following an attempt to use an earlier upgrade installer can be fixed by running a recovery stick and selecting Full Erase option (if recovering to a version prior to V12, you can reuse the license which was emailed to you previously).

   When downgrading from V12 to previous versions of Titan it is also important that the Sapphire DMX panel firmware is downgraded in any consoles with ST-DMX cards (Sapphire Touch, TitanNet Processor, Tiger Touch II and Arena). This is because new features in the firmware are not compatible with previous versions. To downgrade the firmware open USB Expert Console and put any Sapphire DMX Panels into Boot Mode. This is found in the Service Tab. When the panels have re-appeared in boot mode, select Program which will open a file dialog. In the file dialog navigate to C:\Program Files (x86)\Avolites\UsbExpert\Panel Software and select the st_dmx.bin file. This will now install the previous ST-DMX firmware. Once this is complete do the same on all Sapphire DMX panels and then exit Boot mode. Now restart the console and you should now be OK to use the previous version of Titan. When you next upgrade to V12 you will need to carry out the firmware update again.

4. **Touchscreen input on Tiger Touch II consoles can become inverted after running calibration:**

   In some circumstances, it is possible for the touchscreen calibration utility on a Tiger Touch II to leave the touch input inverted. Users of Tiger Touch II consoles are advised not to run the calibration utility at this time.

   If you have been affected by this issue, an interim workaround can be applied by running the calibration utility and tapping the targets upside down, so that the touchscreen is re-calibrated to the correct orientation.

5. **Cue Numbers all turn green when opening playback:**

   After toggling off Chase Snap in the User Settings page, then opening the Playback View window for a chase with multiple steps, multiple steps appear with a green indication that the cue is fired.

6. **Master console sometimes gets stuck in safe mode:**

   The Master console sometimes gets stuck in safe mode when the network cable is removed mid-session and the backup takes over and then reassigned to be the backup console after reconnecting the network cable to the original master. Most of the time the backup console automatically relinquishes control of the TNP and the Master automatically reconnects to the TNP, sometimes the backup console gives you a softkey option of allowing the master console to assign all lines to the TNP, and every now and then the master console gets stuck in safe mode.

7. **Connecting an external touchscreen to a certain TNPs causes internal touchscreen issues:**

   If an external touchscreen is connected to a TNP containing an LV67H motherboard, the internal touchscreen will not be assigned correctly, and will be mapped to the wrong screen.

8. **Android Remote has issues discovering Titan consoles and can disconnect during use:**

   Due to a bug discovered in the Android operating system, certain newer Android phones may fail to discover Titan sessions on the network, and may disconnect seemingly at random while in use. We have published detailed guidance on how to mitigate this issue as FAQ-10035, which can be found at [https://www.avolites.com/support/titan-troubleshooting](https://www.avolites.com/support/titan-troubleshooting). Users wishing for more information on the bug in Android (which we have reported to Google) can find more information at [https://issuetracker.google.com/issues/132686258](https://issuetracker.google.com/issues/132686258).

9. **Remote may crash in particularly complex showfiles:**

   Due to a bug in the underlying communication system, the Titan Remote app may crash when loading or using particularly complex showfiles. Whilst we have made efforts to mitigate this problem, crashes may still occur. If this happens you can usually restart the app to continue.

10. **Cannot run Ai and PC Suite on the same host in a Synergy Session:**

    It is not currently possible to use Synergy in PC Suite if Ai is on the same machine.

11. **Output can pause occasionally for a short time:**

    In certain situations under heavy load, the output can pause briefly.

12. **Synergy Lightmap can very occasionally allow underlying fixture colour to display at high workloads:**
In certain situations where system load is higher than the specified maximum, fixtures running a Synergy Lightmap can occasionally show their underlying fixture colour rather than the colour obtained via Synergy.

13. **Synergy Multiview re-establishes NDI streams when window moved between screens:**
   If the Synergy Multiview window is moved between console screens, the NDI streams must be re-established, which takes a few seconds.

14. **Move in dark doesn't act during the link wait time:**
   Move in dark could act during a cue link time, but it doesn't.

15. **Undo programmer releases all Quick Palette applications:**
   When undoing a change to the programmer, all previously applied quick palettes are released.

16. **Pixel maps in single cues do not fade over fade-in time:**
   Pixel mapped effects do not respect the fade-in time set on a single-cue playback.

17. **Layout Editor Triangle Arrange feature fails on certain fixture types:**
   In layout editor, the triangle arrange feature does not set the height correctly when arranging groups of certain fixtures.

18. **Go key profile on cue playbacks cause fade to snap through black:**
   If the key profile for a cue playback is set to go and a fade-in time is set for the playback, then pressing the 'Go' key profile will cause the playback to fade in from black, instead of crossfading fixtures from their previous state.

19. **For the Pioneer DJ integration to function the console software may need restarting:**
   When opening the Pioneer DJ window on occasion the waveforms will not populate. If this occurs and the bridge software is functioning correctly the software may not have detected the bridge. The console may need to be restarted for the connection to the bridge software to be made.